Tema cerrado 
 
Calificación:
  • 0 votos - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Solucionado Error con XONEJSONSQL
17-11-2017, 01:08 PM
Mensaje: #1
Error con XONEJSONSQL
Hola, estoy tratando de poner en IIS 6 el servicio web de XOne para realizar peticiones online XONEJSONSQL.
Desde XOne me muestra un error 500 (Internal server error) y si abro la dirección desde el navegador, me muestra un error del analizador.
No me deja adjuntar el png asi que pongo un enlace donde se puede ver el error:
https://www.dropbox.com/s/r4c5jj2xqa8jo1...a.png?dl=0
Que puede ser? algun problema de permisos?
Gracias de antemano!
Un saludo!
Encuentra todos sus mensajes
17-11-2017, 01:25 PM
Mensaje: #2
RE: Error con XONEJSONSQL
Hola, la página la tienes que crear en el IIS con los mismos permisos que tenga el XOneManager. Se debe ejecutar con el framework 4.0.
Mira que el config este bien, no sea que este corrupto.
Encuentra todos sus mensajes
20-11-2017, 09:11 AM
Mensaje: #3
RE: Error con XONEJSONSQL
Hola Ruben,
el web.config parece bien configurado y no tiene nada de especial:
Código XOne:
<?xml version="1.0"?>
<configuration>
  <system.web>
    <compilation debug="true" />
  </system.web>
  <system.webServer>
     <modules runAllManagedModulesForAllRequests="true"/>
  </system.webServer>
  <appSettings>
      <add key="debug" value="true"/>
    <add key="isreplicating" value="false"/>
    <add key="ROUTEFILES" value="X:\XOneRepository\ReplicaFiles\"/>    
    <add key="sqlfieldname" value="SQL"/>
    <add key="rowidfieldname" value="ROWID"/>  
    <add key="Connection String" value="Provider=System.Data.SqlClient;Data Source=SERVIDOR\SQLEXPRESS;User Id=XXX;Password=YYY;Initial Catalog=Xone"/>
    <add key="Security Level" value="0"/>
    <add key="Database Operations Allowed" value="select,insert,delete,update"/>
  </appSettings>
</configuration> 

El error que da es:
Mensaje de error del analizador: No se pudo cargar el tipo 'XoneJSONSQL._Default'.

Archivo de origen: /XOneJSON/Default.aspx

Parece que sea algo de la configuración de IIS 6, ya que lo mismo en el IIS7 me ha funcionado a la primera.

La versión de ASP.NET es la 4.0.30319

Un saludo!
Encuentra todos sus mensajes
20-11-2017, 04:04 PM
Mensaje: #4
RE: Error con XONEJSONSQL
Solucionado el problema. Realmente el problema estaba en la red del sistema, con diferentes IIS según configuración del responsable de sistema. Configurado correctamente, todo funciono sin problemas.
Encuentra todos sus mensajes
Tema cerrado 


Salto de foro:


Usuario(s) navegando en este tema: 1 invitado(s)

Contáctanos | XOne | Volver arriba | Volver al contenido | Archivo (Modo simple) | Sindicación RSS