Tema cerrado 
 
Calificación:
  • 0 votos - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Solucionado Problema lupa
06-03-2018, 10:55 AM
Mensaje: #1
Problema lupa
Hola,

Tengo una aplicación con una lupa. Al mantener pulsado un elemento me aparecen las opciones "Ver Editar Eliminar".

Código XOne:
<prop name="MAP_TIENDA" visible="1" type="T" tooltip="Tienda" size="20" title="TIENDA" linkedto="MAP_IDTIENDA" linkedfield="DESCRIPCION" showinline="false" /> 
Necesitamos esto no ocurra con los elementos de la lupa. He probado con los atributos editmask="0" y nomenmask="24" a nivel de coll pero no se me ha solucionado. Por favor, ¿cómo puedo evitar esto?

Y también necesitaríamos que no estuviera seleccionado un elemento al pulsar la lupa y abrirse la lista.

Uso el frame XOneV3 4.8.1.9dev y android 7.1.1.

Gracias,
Un saludo
Daniel
Encuentra todos sus mensajes
06-03-2018, 11:15 AM
Mensaje: #2
RE: Problema lupa
Hola, nomenmask="24" o 0 debería bastar. ¿Estás seguro de que la has puesto en la colección correcta a la que apunta linkedto="MAP_IDTIENDA"?

Juan Carlos Rabanal Villalobos.
Computer Global Software - CGSoft
Encuentra todos sus mensajes
06-03-2018, 11:28 AM
Mensaje: #3
RE: Problema lupa
Hola,

Si estoy seguro.

Código XOne:
<prop name="MAP_IDTIENDA" type="N" visible="0" mapcol="Tiendas" mapfld="ID" /> 

Y esta es la colección:

Código XOne:
<coll name="Tiendas" title="Tiendas" show-selected-item="false"
sql="SELECT t1.ID, t1.CODIGO, t1.DESCRIPCION, t1.CODIGO || ' - ' || t1.DESCRIPCION as MAP_CODIGONOMBRE
    FROM ##PREF##TIENDA t1" 
objname="TIENDA" updateobj="TIENDA" progid="ASData.CASBasicDataObj" filter="ITX_BAJA=0" sort=""
     
group-theme="material" notab="true" show-toolbar="false" editmask="0" nomenmask="24" >
  <
group name="General" id="1">
    <
prop name="ID" type="N" visible="0" />
    <
prop name="CODIGO" type="T" visible="0" />
    <
prop name="DESCRIPCION" type="T" visible="0" />
    <
prop name="MAP_CODIGONOMBRE" type="T" visible="7" />
  </
group>
</
coll

Saludos,
Daniel
Encuentra todos sus mensajes
06-03-2018, 11:32 AM
Mensaje: #4
RE: Problema lupa
Pasame el proyecto a mi correo para que lo revise: jcrabanal@xone.es

Juan Carlos Rabanal Villalobos.
Computer Global Software - CGSoft
Encuentra todos sus mensajes
06-03-2018, 01:28 PM
Mensaje: #5
RE: Problema lupa
Solucionado en la versión 4.8.1.36dev del framework v3.

Juan Carlos Rabanal Villalobos.
Computer Global Software - CGSoft
Encuentra todos sus mensajes
Tema cerrado 


Salto de foro:


Usuario(s) navegando en este tema: 1 invitado(s)

Contáctanos | XOne | Volver arriba | Volver al contenido | Archivo (Modo simple) | Sindicación RSS